US experiencing an outage

Incident Report for Automate MFT

Resolved

Public cloud vendor outage disrupted Automate MFT sign-ins and led to an elevated error rate on our services. Normal operation resumed after the vendor resolved the issue.
Posted Oct 20, 2025 - 09:27 UTC

Investigating

We have noticed an elevated error rate on our services.
Posted Oct 20, 2025 - 07:15 UTC
This incident affected: US.