Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Mar 12, 2026 - 07:52 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 12, 2026 - 06:50 UTC
Scheduled
We will perform scheduled maintenance for Automate MFT on March 12 during the following time window: EU Environment - https://eu.mft.progress.com - 06:50 – 07:50 UTC
Impact: During these time periods, the Automate MFT UI will be inaccessible.
No impact on task execution: All scheduled tasks will continue to run as normal during the maintenance window.